Re: upgrading with murder/aggregator

From: Andrew Morgan (no email)
Date: Fri May 28 2010 - 13:58:52 EDT

  • Next message: Torsten Schlabach: "Re: upgrading with murder/aggregator"

    On Fri, 28 May 2010, Ragnar Sundblad wrote:

    > Is murder/aggregator backwards compatible with older imap
    > servers?
    >
    > We want to migrate form a single 2.1.18 cyrus imap server to
    > multiple 2.3.x servers. An idea is to insert a common
    > murder/aggregator in front of both the 2.1.18 server and the
    > new servers, and seamlessly migrate users. Would this be
    > doable?

    Yes, you can do this. However, your frontend proxy server must be running
    the old version until all of your backends have been upgraded.

    Version 2.3 of the proxy server tries to issue commands to the backends
    that older version of Cyrus do not support. I don't know if there are
    other incompatibilities between 2.1 and 2.2.

    As always, it is a good idea to test this before exposing it to your
    users. I suggest bringing up a 2.3 mupdate master, 2.3 backend, and 2.1
    frontend. Then, use Cyrus' built-in mailbox rename/move feature to
    migrate a mailbox from the 2.1 backend to the 2.3 backend. Test, test,
    test!

             Andy

    ----
    Cyrus Home Page: http://cyrusimap.web.cmu.edu/
    Cyrus Wiki/FAQ: http://cyrusimap.web.cmu.edu/twiki
    List Archives/Info: http://asg.web.cmu.edu/cyrus/mailing-list.html
    

  • Next message: Torsten Schlabach: "Re: upgrading with murder/aggregator"





    Hosted Email Solutions

    Invaluement Anti-Spam DNSBLs



    Powered By FreeBSD   Powered By FreeBSD