Problem using non-plain SASL + Postfix + LDAP

Ali dot Naddaf at trilogy dot com
Date: Thu Jun 24 2004 - 11:53:44 EDT

  • Next message: Igor Brezac: "Re: Problem using non-plain SASL + Postfix + LDAP"

    Hello everyone.

    I have installed postfix, and am using LDAP for various lookups. I also
    want to let smtp relay for remote users and am trying to set up Cyrus-SASL
    for that (to authenticate against my LDAP directory). Following the
    instructions, I have been able to authenticate in plain mode but have had
    no success with other methods such as DIGEST,CRAM, ...

    To see what is going on, I started saslauthd with "-d". When I am using
    the PLAIN method, I see some debug info on the console that I started the
    daemon, but when I change the encryption method in my MUA, I don't see any
    debug info, as if SASL is not even contacted. Here is some more info:

    -------------------------------------------------------------

    telnet naddaf.net 25
    220 florence.naddaf.net ESMTP Postfix (2.0.19-20040312)
    ehlo naddaf.net
    250-florence.naddaf.net
    250-PIPELINING
    250-SIZE 10240000
    250-VRFY
    250-ETRN
    250-AUTH CRAM-MD5 DIGEST-MD5 PLAIN OTP
    250-AUTH=CRAM-MD5 DIGEST-MD5 PLAIN OTP
    250 8BITMIME
    AUTH PLAIN YWxpAGFsaQB0ZXN0
    235 Authentication successful

    -------------------------------------------------------------

    Could some one please tell me what I need to do or how I can debug this
    problem?
    Thanks,
    Ali.


  • Next message: Igor Brezac: "Re: Problem using non-plain SASL + Postfix + LDAP"





    Hosted Email Solutions

    Invaluement Anti-Spam DNSBLs



    Powered By FreeBSD   Powered By FreeBSD