Re: Help: SASL doesn't want to build with heimdal


Subject: Re: Help: SASL doesn't want to build with heimdal
From: Etienne Goyer (etienne dot goyer at linuxquebec dot com)
Date: Fri May 23 2003 - 09:04:39 EDT


I am not quite sure, but I think you need to specify
"--with-gssapi=/usr/heimdal" instead of "--with-gssapi=/usr/heimdal/lib"
to configure. At least, that's how I do it and It Work For Me (TM).

On Thu, May 22, 2003 at 04:58:47PM -0700, Rob Tanner wrote:
> Hi,
>
> I've built and installed heimdal-0.6 kerberos5 and now trying to build
> Cyrus SASL 2.1.13 on Solaris 2.7. The problem is the configure run
> doesn't recognize heimdal and wants to build against MIT instead. I do not
> have the MIT libraries installed, although for whatever reason, the
> include files are on the system. When I removed them, the configure
> disables gssappi.
>
> I'm using the following pre-scripted configure process:
>
> #! /usr/local/bin/bash
>
> export CPPFLAGS="-I/usr/local/ssl/include -I/usr/heimdal/include"
> export LDFLAGS="-L/usr/local/ssl/lib -L/usr/heimdal/lib"
>
> make distclean
>
> ./configure \
> --with-saslauthd \
> --with-pwcheck \
> --with-openssl \
> --enable-gssapi=/usr/heimdal/lib \
> --enable-plain \
> --with-ldap
>
> Any ideas?
>
> Thanks,
> Rob
>
>
> Rob Tanner
> Linfield College
> McMinnville, Oregon
> rtanner+cyrus at linfield dot edu

-- 
Etienne Goyer                    Linux Québec Technologies Inc.
http://www.LinuxQuebec.com       etienne dot goyer at linuxquebec dot com







Hosted Email Solutions

Invaluement Anti-Spam DNSBLs



Powered By FreeBSD   Powered By FreeBSD