New on the list


Subject: New on the list
From: Dan Vande More (dvm at firstlink dot com)
Date: Thu Apr 03 2003 - 11:34:39 EST


Forgive me if this question has been answered, but I did search the list
as well as google and did not find anything that could help me.

I'm trying to compile SASL 2.1.12 on my i386/openbsd box.

I've done this:

./configure --enable-plain --enable-login --disable-krb4
--disable-gssapi --with-mysql --without-des --enable-static

And got this on postfix start:

Could not find a dlname line in .la file: libsasldb.la
Could not find a dlname line in .la file: libplain.la
Could not find a dlname line in .la file: libanonymous.la
------------------------------------------------------------------------
---------
I've also done this:

./configure --enable-plain --enable-login --disable-krb4
--disable-gssapi --with-mysql --without-des --enable-static
--disable-shared

And got this during the make:

dlopen.o: Undefined symbol `_anonymous_server_plug_init' referenced from
data segment
dlopen.o: Undefined symbol `_anonymous_client_plug_init' referenced from
data segment
dlopen.o: Undefined symbol `_crammd5_server_plug_init' referenced from
data segment
dlopen.o: Undefined symbol `_crammd5_client_plug_init' referenced from
data segment
dlopen.o: Undefined symbol `_digestmd5_server_plug_init' referenced from
data segment
dlopen.o: Undefined symbol `_digestmd5_client_plug_init' referenced from
data segment
dlopen.o: Undefined symbol `_login_server_plug_init' referenced from
data segment
dlopen.o: Undefined symbol `_login_client_plug_init' referenced from
data segment
dlopen.o: Undefined symbol `_otp_server_plug_init' referenced from data
segment
dlopen.o: Undefined symbol `_otp_client_plug_init' referenced from data
segment
dlopen.o: Undefined symbol `_plain_server_plug_init' referenced from
data segment
dlopen.o: Undefined symbol `_plain_client_plug_init' referenced from
data segment
dlopen.o: Undefined symbol `_sasldb_auxprop_plug_init' referenced from
data segment
dlopen.o: Undefined symbol `_mysql_auxprop_plug_init' referenced from
data segment

------------------------------------------------------------------------
-------------
I've done the normal stuff, like ln -s /usr/local/lib/sasl2
/usr/lib/sasl2

Additionally, why can I not do a make clean with SASL, all I get is a
error on Line 315 of the of the make file. Not very helpful , it just
says error 1.

And I found no documentation on how to fix the "ln -s plugin_common.o
File exists"bug.
If I added what looked the like the diff from cvs, it seemed to break
everything even worse.
The steps I use when I get this error are as follows:

vi lib/Makefile
Comment this line:
#ln -s ../plugins/plugin_common.o plugin_common.o
Do this:
mv ./lib/plugin_common.o ./lib/plugin_common.o.old
Then remake

Thanks for any help!

-Dan







Hosted Email Solutions

Invaluement Anti-Spam DNSBLs



Powered By FreeBSD   Powered By FreeBSD